Drittanbieter Lösungen nicht GPL-kompatibel?

Bei der Entwicklung der Erweiterung ssch_simpleviewer wurde ich darauf aufmerksam gemacht, dass das Angebot auf simpleviewer.net wohl nicht GPL-kompatibel sei. Auf Grund der Tatsache, dass die Erweiterung ssch_simpleviewer mit den einzelnen swf´s von simpleviewer.net ausgeliefert wird, widerspricht die Erweiterung damit der Guideline unter http://wiki.typo3.org/Overview_Extension_manuals#GPL-incompatible_extensions_.28to_be_removed_from_TER.29.
Abhilfe schafft dabei die Erweiterung package_manager.
Zukünftig wird die Erweiterung ssch_simpleviewer die Einzelnen swf´s nicht mehr direkt mitliefern. Diese müssen dann über den package_manager
explizit installiert werden.

Auf die Weise ist die Erweiterung ssch_simpleviewer frei von GPL-inkompatiblen Drittanbieterlösungen.
Ich habe bereits alle Maßnahmen im Entwicklungs-Branch vorbereitet.
Allerdings enthält die Erweiterung package_manager für mich noch einen Mangel beim Download-Prozess (keine Unterstützung von Callback-Funktionen).
Ich habe den Autor bereits angeschrieben und warte noch auf eine Rückmeldung.
Danach spiele ich die aktuelle Version der Erweiterung ins TER.

Veröffentlicht von

avatar

Sebastian Schreiber

Ich bin 1980 in Bergisch Gladbach geboren. Nach dem Abitur und Zivildienst habe ich 2000 an der Fachhochschule Lippe & Höxter das Studium der Medienproduktin begonnen und nach längeren Aufenthalten in Valencia und Berlin 2003 das Studium mit dem Abschluss Bachelor of Science in Medienproduktion abgeschlossen. Nach einer Festanstellung kurz nach dem Studium in einer kleinen Webagentur in Köln mit Schwerpunkt TYPO3 bin ich nun seit 2008 freiberuflicher Webentwickler.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.